Results 1 to 6 of 6
  1. #1
    Forum User
    Join Date
    Oct 2006
    Location
    Ascot
    Posts
    76

    williams 1 Engine stalling

    I have a problem with my williams 1.
    The engine has started cutting out and stalling especially when going over bumps.

    After checking my battery connections with no sign of a problem, I tried spraying carb cleaner in to the carb and the other two small holes behind the air filter (I guess one is the potentiometer).
    This fixed the problem the car was back to good as new.

    However, soon afterwards I started getting the same symptoms which got worse and worse.
    So I sprayed again and this time opened up the carb flap which was very black and oily on the otherside.
    I cleaned the flap, and took the car for a 4 mile test drive and it was great again. But all trips since then on the same weekend the car has deteriorated to stalling and losing power again.
    Has anyone any ideas of what i should do next?

    desperate Nick

    ps. btw I have checked my oil level and it is on the max, no sign of any lose.

  2. #2
    Forum User Wobba's Avatar
    Join Date
    Sep 2006
    Location
    Willy1 217 & 172 Ph1
    Posts
    9,183
    Sounds like a bad earth or maybe wiring issue, maybe shorting out somewhere like the starter motor or ISCV or throttle body. Have a look around the relays and the back of the engine where the heatshield is near the starter as well, if insecure they can cause shorting out.

  3. #3
    Forum User
    Join Date
    Oct 2006
    Location
    Ascot
    Posts
    76
    Thanks , but when I cleaned the carburettor the fault went away, but gradually came back after a few weeks. Doiesn't that suggest it's the carb getting dirty? and if so why would it get dirty?

  4. #4
    Forum User
    Join Date
    Oct 2006
    Location
    Ascot
    Posts
    76
    Sorry, of course it's not a carburettor, I mean the flap behind the air filter, probably a choke flap

  5. #5
    Forum User Wobba's Avatar
    Join Date
    Sep 2006
    Location
    Willy1 217 & 172 Ph1
    Posts
    9,183
    Quote Originally Posted by Nickysteveo View Post
    Sorry, of course it's not a carburettor, I mean the flap behind the air filter, probably a choke flap
    That's the throttle body. Did you take the whole thing off or just spray it with stuff? Can you get a picture of the whole unit and the red parts and ISCV plug?

  6. #6
    Sounds more like the idle speed control valve, take it off, clean it thoroghly with brake cleaner, spray it with wd40 & refit

    As for the bits getting oily, they're supposed to get like that as the oil breather pipes go to the airbox, you just have to clean built up crap off them them from time to time


 

Similar Threads

  1. Stalling!
    By cliokiz in forum Mechanical
    Replies: 5
    Last Post: 19-09-2011, 00:03
  2. Stalling..
    By 1995clio16v in forum Mechanical
    Replies: 3
    Last Post: 15-06-2008, 09:43
  3. Engine stalling under heavy breaking.
    By Wobba in forum Mechanical
    Replies: 7
    Last Post: 25-05-2008, 12:30
  4. stalling
    By bill. in forum Mechanical
    Replies: 6
    Last Post: 23-12-2006, 10:50
  5. Stalling Engine.
    By Smokey McPot in forum Mechanical
    Replies: 2
    Last Post: 14-03-2006, 13:20

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •